ロードバイク 自転車日記

2017年7月18日 9:29 PM ブログ

6月25日から画面表示がされていないことに昨日気づいたので対処してみました。原因はPHP7.0に対応していないプラグインを残していながら、サーバのphpバージョンを5.4から7.0に切り替えたからです。

PHP7.0に対応していないプラグインを有効化していると画面が白くなるようです。プラグインを無効化したところ画面が表示されました。

方法としてはまずFTPソフトでプラグインを全無効化します。FTPソフトでpluginsを探し名前をplugins.holdに変更、新しいフォルダ(plugins)を作成し同じディレクトリにアップロードする。wordpress編集画面まで行けるようになったら、新しく作成したpluginsフォルダを削除、plugins.holdの名前をpluginsに戻す。プラグインが全て無効化されているので一つずつ有効化して画面表示できるか確認していきます。

Exec-PHPの対応

Exec-PHPも同様に7.0に対応していなかったのでPHPのバージョンを7に上げてみたを参考にして何とかブログを再開することができました。

PHPのバージョンアップする前にバックアップをとり動作確認が必要であることを再確認させられた一日だった。



コメントを残す

メールアドレスが公開されることはありません。